Esky Honey Bee King 2 HELP!!! - WattFlyer RC Electric Flight Forums - Discuss radio control eflight

Beginners - Helis A forum where beginners can get help on the fundamentals for experts who know their stuff!

Esky Honey Bee King 2 HELP!!!

Old 03-24-2009, 11:18 PM
  #1  
MORGAN420
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 9
Unhappy Esky Honey Bee King 2 HELP!!!

okay so im new to rc helicopters, but im no moron when it comes to reading instructions...
so heres what ive read when first starting the heli:

charge the battery
turn on transmitter
throttle off
throttle trim down
idle off
set all other trims to center position
extend the antennae
plug in the battery
let it trim itself out
fly

okay so i did all of that, except as soon as i plugged in my battery(step 8) the helicopter starts up and spinning....not ready to take off...but spinning nonetheless.
i unplug it
isnt it supposed to start when i tell it to, instead of in my hands???
maybe you can help me out?
much appreciated
MORGAN420 is offline  
Old 03-24-2009, 11:21 PM
  #2  
MORGAN420
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 9
Default

this is a brand new, right out of the box, RTF esky hbk2
MORGAN420 is offline  
Old 03-24-2009, 11:21 PM
  #3  
Twmaster
Registered User
 
Twmaster's Avatar
 
Join Date: Aug 2005
Location: Dallas, TX, USA
Posts: 6,632
Default

Check that your idle up switch is in the correct position. I know you mentioned that but check it again.

Also, it would not be unheard of for the factory to have the settings wrong.
Twmaster is offline  
Old 03-24-2009, 11:23 PM
  #4  
MORGAN420
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 9
Default

idle switch was down
i even clicked it up but then it wanted to leave my hands
id assume the factory messed something up...
but what???
MORGAN420 is offline  
Old 03-24-2009, 11:25 PM
  #5  
Twmaster
Registered User
 
Twmaster's Avatar
 
Join Date: Aug 2005
Location: Dallas, TX, USA
Posts: 6,632
Default

From my copy of the King II manual...

"Move the switch backwards to turn off inverted flight switch"

So the idle up switch needs to point to the rear.

Also make sure the throttle channel reversing switch is pointing the correct direction. (down for mode II transmitter)
Twmaster is offline  
Old 03-24-2009, 11:28 PM
  #6  
MORGAN420
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 9
Default

yes sir did all that...
i checked to see what other people have said and tried all the switched before asking a forum myself..
idle switch points to the back, gyro is down, throttle down, throttle idle down, throttle reversing switch (along with the other 3) down.

i have no idea, the blades wont stop spinning unless i unplug the battery
MORGAN420 is offline  
Old 03-25-2009, 01:36 AM
  #7  
Twmaster
Registered User
 
Twmaster's Avatar
 
Join Date: Aug 2005
Location: Dallas, TX, USA
Posts: 6,632
Default

At this point I would make sure all the leads going to the RX are in their correct sockets.
Twmaster is offline  
Old 03-25-2009, 01:44 AM
  #8  
MORGAN420
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 9
Default

thats what i assumed but i wanted an experts opinion
ill check it out and tell you if that was the problem

thanks a lot!
MORGAN420 is offline  
Old 03-25-2009, 02:27 AM
  #9  
MORGAN420
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 9
Default

well i checked to see if the servos were all connected in the right place

and they are...
im truly stumped
this heli has been nothing but problems for me
MORGAN420 is offline  
Old 03-25-2009, 11:26 PM
  #10  
MORGAN420
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 9
Default

yeah still hasnt helped....
any more ideas??
MORGAN420 is offline  
Old 03-26-2009, 01:12 AM
  #11  
Twmaster
Registered User
 
Twmaster's Avatar
 
Join Date: Aug 2005
Location: Dallas, TX, USA
Posts: 6,632
Default

I'm stumped.
Twmaster is offline  
Old 03-26-2009, 01:22 AM
  #12  
MORGAN420
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 9
Default

what!? nothing at all?
no reason why it starts on it own other than those??
MORGAN420 is offline  
Old 03-26-2009, 02:00 AM
  #13  
Twmaster
Registered User
 
Twmaster's Avatar
 
Join Date: Aug 2005
Location: Dallas, TX, USA
Posts: 6,632
Default

Well, there are other things. Bad TX or RX. Bad speed control...
Twmaster is offline  
Old 03-26-2009, 02:44 AM
  #14  
MORGAN420
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 9
Default

What's a tx and rx again??
MORGAN420 is offline  
Old 03-26-2009, 03:50 PM
  #15  
bassplayinDude
Member
 
Join Date: May 2007
Posts: 792
Default

Tx = Transmitter
Rx = Receiver
bassplayinDude is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
notascoobie!
General RC E-Heli Talk
9
12-26-2008 10:01 PM
KE4NYV
General RC E-Heli Talk
0
06-20-2008 01:05 AM
User1200
Helicopters- Electric For Sale & WTB
5
03-19-2008 07:57 PM
OV10Mech
Helicopters- Electric For Sale & WTB
0
03-17-2008 03:49 AM
PcKSnipE
Ebay for sale
2
02-28-2008 08:53 AM
2 , bee , esky , honey

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Esky Honey Bee King 2 HELP!!!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.07701 seconds with 13 queries