Beginners - Helis A forum where beginners can get help on the fundamentals for experts who know their stuff!

Dauphin Problem Help

Old 03-14-2009, 07:19 AM
  #1  
dorkman
New Member
Thread Starter
 
Join Date: Mar 2009
Posts: 1
Angry Dauphin Problem Help

I just bought a 2.4G E-Sky Dauphin. I tryed to install the turbo shaft but the swashplate did not fit. So I placed all the stock parts back. Now when I try to start it the green light will never turn on. It just stays red the whole time. It will flash red like 3 times then nothing. The servos will make make quick jolt then, nothing. Does anyone have any clue?
dorkman is offline  
Old 03-15-2009, 05:01 AM
  #2  
jasmine2501
Custom User Title
 
jasmine2501's Avatar
 
Join Date: Jul 2007
Location: Lakewood, CO
Posts: 2,373
Default

You moved it too much, it is not seeing a zero throttle signal, or it is not seeing a signal at all. It won't arm unless you go to zero throttle.
jasmine2501 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Hermod
Beginners - Helis
2
12-30-2008 04:16 PM
shschon
Helicopters- Electric For Sale & WTB
0
10-12-2008 12:57 AM
Liquidity
Micro Sized Electric Helicopters
2
09-11-2008 03:53 AM
Shocktherapy
General RC E-Heli Talk
2
04-23-2008 06:09 AM
Shocktherapy
Beginners - Helis
7
04-19-2008 05:18 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Dauphin Problem Help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.09885 seconds with 15 queries