General Electric Discussions Talk about topics related to e-powered RC flying

Adapter suggestion? Any help?

Old 04-06-2021, 11:16 AM
  #1  
davehetfield
New Member
Thread Starter
 
davehetfield's Avatar
 
Join Date: Apr 2021
Posts: 1
Default Adapter suggestion? Any help?

Hi everyone, I have an FMS Kingfisher PnP aircraft and have just picked up the Spectrum AR610 receiver. During assembly it and prepare to install the receiver and notice the wires from the servos other than the sockets on rx.
Need your help? Thanks
davehetfield is offline  
Old 04-06-2021, 12:23 PM
  #2  
solentlife
Super Contributor
 
solentlife's Avatar
 
Join Date: Oct 2010
Location: Ex UK Brit now in Latvia west coast - Ventspils
Posts: 12,698
Default

The servos in the Kingfisher (I assume this is the 1400mm version with the three modes - Skis, floats, wheels ?) are standard JR format 3 pin servos .... which most standard Rx's will accept.

https://www.horizonhobby.com/product.../FMM103PF.html

Checking AR610 manual online shows same JR style ..... so little confused why you cannot connect ?

https://www.spektrumrc.com/Products/...rodID=SPMAR610


solentlife is offline  
Old 05-01-2021, 02:01 AM
  #3  
stemo99
Member
 
Join Date: Sep 2010
Location: So. Jersey
Posts: 45
Default

The receiver slots on the AR610 are tight, and if your servo plug has a little plastic “key” molded on it, get an exacto knife and shave the key off. Note the polarity of the wires and the insert the plug into the receiver.
stemo99 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rb51
General Electric Discussions
0
02-28-2020 10:24 PM
Old 'N Slow
Beginners
7
09-01-2013 04:38 AM
partzee
Batteries & Chargers
4
12-07-2011 08:38 PM
mclarkson
General Electric Discussions
12
11-26-2011 10:09 PM
G Rated F Bomb
Power Systems
1
10-15-2011 03:31 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Adapter suggestion? Any help?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.06797 seconds with 11 queries