Blade cp pro inverted - WattFlyer RC Electric Flight Forums - Discuss radio control eflight

E-Flite Helicopters Discuss E-Flite helicopters in this forum such as the Blade CX, Blade CX2, Blade CP Pro and all other E-Flite rc helis.

Blade cp pro inverted

Old 12-05-2008, 11:22 PM
  #1  
Futurepilot13
Member
Thread Starter
 
Futurepilot13's Avatar
 
Join Date: Dec 2008
Location: Bullard, TX
Posts: 39
Default Blade cp pro inverted

Does anyone no how to uninvert the blade cp pro because it is inverted now i dont know how to uninvert it for normal flight mode.

Please help me.
James,
Futurepilot13 is offline  
Old 12-06-2008, 04:33 AM
  #2  
vortex05
Blade CP, Blade 400
 
Join Date: May 2007
Location: Toronto, ON, Canada
Posts: 693
Default

I don't understand you mean turn off the idle up switch?
vortex05 is offline  
Old 12-06-2008, 06:06 AM
  #3  
Futurepilot13
Member
Thread Starter
 
Futurepilot13's Avatar
 
Join Date: Dec 2008
Location: Bullard, TX
Posts: 39
Default No

No i mean when i start it up as i slowly speed up it just pushes the air up instead of down, I dont know how to make the air go down it is in inverted flight mode. i need it in normal flight mode.

Thanks,
James
Futurepilot13 is offline  
Old 12-06-2008, 06:52 AM
  #4  
vortex05
Blade CP, Blade 400
 
Join Date: May 2007
Location: Toronto, ON, Canada
Posts: 693
Default

Did you plug the motor wires in reverse? Have your checked to see if any of your channels on your Tx have been changed? (the little dip switches at the bottom of the tx)
vortex05 is offline  
Old 12-06-2008, 05:34 PM
  #5  
Futurepilot13
Member
Thread Starter
 
Futurepilot13's Avatar
 
Join Date: Dec 2008
Location: Bullard, TX
Posts: 39
Default Yeah

Yes i cheched that to man this is really getting me PO. LOL
well thanks for your help mabey someone else can help me like you did.
Thanks, James
Futurepilot13 is offline  
Old 12-06-2008, 06:26 PM
  #6  
vortex05
Blade CP, Blade 400
 
Join Date: May 2007
Location: Toronto, ON, Canada
Posts: 693
Default

I guess if you could post a video or a picture of what the heli looks like with the motor disconnected but the throttle in the position that it would be in when in flight it would help us judge the blade angle.

If you can take 2 pics 1 with the throttle at 0 and one with it at 100% we can determine if you have it set at the right angles.
vortex05 is offline  
Old 12-06-2008, 06:31 PM
  #7  
TDisaster
Super Contributor
 
TDisaster's Avatar
 
Join Date: Jan 2008
Location: Kansas City, KS
Posts: 1,020
Default

Put your blades on upside down?
Hey it happens .
TDisaster is offline  
Old 12-09-2008, 06:07 PM
  #8  
Futurepilot13
Member
Thread Starter
 
Futurepilot13's Avatar
 
Join Date: Dec 2008
Location: Bullard, TX
Posts: 39
Default Yes

Yeaha ive done that i think i know the pron\blem if it is not the problem then ill heep yall up to date thanks for yalls time,
James
Futurepilot13 is offline  
Old 02-25-2009, 04:18 PM
  #9  
EpoweredRc
3D Flyer
 
EpoweredRc's Avatar
 
Join Date: Aug 2005
Location: B.N.R in Paulding now In Buchanan,GA
Posts: 2,200
Default

I would say the blades on backwards or the motor running wrong direction. I dun both of those with my first CP I felt so stupid when someone told me HA ha
EpoweredRc is offline  
Old 02-25-2009, 05:55 PM
  #10  
RyuuChi
Member
 
Join Date: Apr 2008
Posts: 510
Default

did you try reversing the cyclic servos? it sounds to me like they're moving the wrong direction when you throttle up. This is not "inverted mode" I'm guessing that you're using the stock radio so there's no way to reverse the swash mix, so just try reversing the three servos that are on your cyclic control. let us know if that works.
RyuuChi is offline  
Old 02-26-2009, 05:19 AM
  #11  
Alpha_&_Omega
Too many birds
 
Join Date: May 2008
Location: New Jersey!
Posts: 54
Default

try moving the throttle past mid stick (the left stick). sound like you may be in idle up mode...a.k.a stunt mode. up until mid stick you will have negative pitch... so you can fly up side down. past mid sick you should be able to get some downward thrust. I you know this already, sorry for the basics, but its a common mistake.

if you do know this, check your servo movements and pitch settings.
Alpha_&_Omega is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
20Q
E-Flite Helicopters
43
07-29-2010 02:21 PM
tcorn
E-Flite Helicopters
4
10-27-2007 05:33 PM
rfalls86
Helicopters- Electric For Sale & WTB
3
10-16-2007 02:23 PM
vortex05
E-Flite Helicopters
7
07-10-2007 02:45 AM
kmagvette
E-Flite Helicopters
36
06-17-2007 11:39 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Blade cp pro inverted


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.10158 seconds with 15 queries