Heads UP RC discussion Heads up RC discussion and support. Monitored by Heads UP RC.

Help Can't set throttle on HURC 50 Amp ESC

Old 09-05-2012, 02:39 AM
  #1  
hardingham
New Member
Thread Starter
 
Join Date: Sep 2012
Posts: 2
Default Can't set throttle on HURC 50 Amp ESC

I have a new HURC 50 A ESC that I'm trying to hook up to a Spektrum AR500. I've connected it to a 5 A external UBEC, which I've plugged in to a spare channel on the receiver, while the ESC plug is connected to the THRO channel, with red wire disabled. The receiver is bound OK to the transmitter and will power servos but not the throttle channel. I have carefully followed the recommended steps for programming the ESC to learn the throttle range, but all I'm getting is a series of steady continuous beeps after the musical tone. My throttle setting in my transmitter (a DX7) is normal not reversed. I've tried setting the subtrim to Low -100. I did successfully get my setup to work with an AR6200 and a little Orange receiver, so I don't think I've made a trivial mistake like inserting a plug the wrong way. Anything I do, I just get the continuous beeps from the ESC.
Should I try rebinding the receiver, then go through the throttle range adjustment on the ESC?
Any advice much appreciated. Thanks!
hardingham is offline  
Old 09-05-2012, 02:58 AM
  #2  
all_up_in_the_air
HeadsUp RC.com
 
Join Date: Jan 2007
Posts: 112
Default

Originally Posted by hardingham View Post
I have a new HURC 50 A ESC that I'm trying to hook up to a Spektrum AR500. I've connected it to a 5 A external UBEC, which I've plugged in to a spare channel on the receiver, while the ESC plug is connected to the THRO channel, with red wire disabled. The receiver is bound OK to the transmitter and will power servos but not the throttle channel. I have carefully followed the recommended steps for programming the ESC to learn the throttle range, but all I'm getting is a series of steady continuous beeps after the musical tone. My throttle setting in my transmitter (a DX7) is normal not reversed. I've tried setting the subtrim to Low -100. I did successfully get my setup to work with an AR6200 and a little Orange receiver, so I don't think I've made a trivial mistake like inserting a plug the wrong way. Anything I do, I just get the continuous beeps from the ESC.
Should I try rebinding the receiver, then go through the throttle range adjustment on the ESC?
Any advice much appreciated. Thanks!
The continous beeping indicates one of two things:
1. Throttle range is not set.
2. ESC is not receiving instructions from the receiver.

Considering that you said the ESC works with other receivers, there is likely an issue with your AR500 receiver. (You may want to test the AR500 with a different ESC to see if it functions properly).
I suggest re-binding, then trying to set the throttle range again. If that doesn't solve the problem, you'll need to use a different receiver.
Hope this is helpful to you
all_up_in_the_air is offline  
Old 09-05-2012, 12:30 PM
  #3  
hardingham
New Member
Thread Starter
 
Join Date: Sep 2012
Posts: 2
Default thanks

Very helpful. Will try as you suggest.

E
hardingham is offline  
Old 09-05-2012, 02:57 PM
  #4  
NJSwede
3D wannabe
 
NJSwede's Avatar
 
Join Date: Nov 2010
Location: New Jersey, USA
Posts: 1,893
Default

If that doesn't work, by all means contact HeadsUp! They usually get back with a relevant answer within an hour or so.
NJSwede is offline  
Old 09-05-2012, 04:14 PM
  #5  
kyleservicetech
Super Contributor
 
kyleservicetech's Avatar
 
Join Date: Apr 2008
Location: Wisconsin, USA
Posts: 8,952
Default

Originally Posted by hardingham View Post
I have a new HURC 50 A ESC that I'm trying to hook up to a Spektrum AR500. I've connected it to a 5 A external UBEC, which I've plugged in to a spare channel on the receiver, while the ESC plug is connected to the THRO channel, with red wire disabled. The receiver is bound OK to the transmitter and will power servos but not the throttle channel. I have carefully followed the recommended steps for programming the ESC to learn the throttle range, but all I'm getting is a series of steady continuous beeps after the musical tone. My throttle setting in my transmitter (a DX7) is normal not reversed. I've tried setting the subtrim to Low -100. I did successfully get my setup to work with an AR6200 and a little Orange receiver, so I don't think I've made a trivial mistake like inserting a plug the wrong way. Anything I do, I just get the continuous beeps from the ESC.
Should I try rebinding the receiver, then go through the throttle range adjustment on the ESC?
Any advice much appreciated. Thanks!
This thread might held determine if your receiver has issues. Use the digital multimeter to check the output signal of your AR500 receiver, and compare that to your orange receiver.

http://www.wattflyer.com/forums/showthread.php?t=54123
kyleservicetech is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
CHELLIE
Hi-Performance and Sailplanes
2014
02-25-2018 11:51 AM
AEAJR
Beginners
165
06-28-2017 04:22 PM
celticflyer
Power Systems
4
05-01-2012 12:14 PM
gone2fly2
Power Systems
0
04-20-2011 09:18 PM
gone2fly2
Motors and Speed Controllers for sale & WTB
0
04-06-2011 01:38 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Help Can't set throttle on HURC 50 Amp ESC


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.07251 seconds with 11 queries