Search: Posts Made By: RC Fan Chris
Showing results 1 to 4 of 4
Search took 0.00 seconds.
06-13-2012, 04:45 AM
Replies: 14
Views: 6,912
Posted By RC Fan Chris

Update: the reason the first plane's motor didn't...

Update: the reason the first plane's motor didn't turn properly was a loose, corroded soldered connection between the ESC and one of the wires going to the motor. It was resoldered and now everything...
06-11-2012, 07:29 PM
Replies: 14
Views: 6,912
Posted By RC Fan Chris

Good news. I tested the second plane , making...

Good news. I tested the second plane , making sure the motor to ESC connections were secure, and everything worked perfectly. However, I used a different, older Rx and Tx for this because the newer...
06-11-2012, 04:18 AM
Replies: 14
Views: 6,912
Posted By RC Fan Chris

I charged and balanced the batteries right...

I charged and balanced the batteries right before. I didn't check the voltages though.
06-11-2012, 03:32 AM
Replies: 14
Views: 6,912
Posted By RC Fan Chris

Exclamation Problem with either LiPo's, ESC's, or BL motors...

I have 2 lipo's with identical specs: 3S, 25C, 2200 mAh. Just recently, I tried to fly a plane with a BL motor with one of the two lipos when a weird problem came up. When I throttled the motor up,...
Showing results 1 to 4 of 4


 
Forum Jump

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.09476 seconds with 7 queries